Virtualização e Otimização de Infraestrutura

Informações sobre implementação e otimização da infraestrutura de CORE IO

Problema para distribuir o client do SCCM no 2008 ou 2008 R2?

Olá,

Montando ambientes para demostrações cai em uma verdadeira “sinuca de bico”. O produto instala normalmente, os pré requisitos eram atendidos mas no final, para minha decepção, o client não instalava. Inclusive na própria máquina o erro ocorria.  Confused smile

Bom, pesquisando internamente na Microsoft encontrei o que é o problema. Na verdade não é bem um problema, mas sim como o WEBDAV trabalha.

Para quem não sabe, o WEBDAV é parte do IIS e para que o SCCM funcione corretamente no Windows 2008 ou Windows 2008 R2, necessita que ele seja pré-configurado antes da instalação do produto.

Como fazer isso?? Simples. abaixo segue um script que deverá ser colocado em C:\Windows\System32\Inetsrv

#########################

@ECHO OFF
REM Habilitando o WebDav
ECHO Habilitando o WebDav
Appcmd set config “Default Web Site” /section:system.webServer/webdav/authoring /enabled:”True”  /commit:apphost
ECHO.

REM Adicionando o authoring rule
ECHO Adicionando o Authoring Rule
AppCmd set config “Default Web Site” /section:system.webServer/webdav/authoringRules /+[users=’*’,path=’*’,access=’Read’] /commit:apphost
ECHO.

REM Anterando Propriedades

ECHO Configurando propriedades do WebDav

Appcmd set config “Default Web Site” /section:system.webServer/webdav/authoring /fileSystem.allowHiddenFiles:”True”  /commit:apphost
appcmd set config “Default Web Site” /section:system.webServer/webdav/authoring /properties.allowAnonymousPropfind:”True” /properties.allowInfinitePropfindDepth:”True” /properties.allowCustomProperties:”False”  /commit:apphost
AppCmd set config “Default Web Site/” /section:system.webServer/security/requestFiltering /fileExtensions.applyToWebDAV:false /commit:apphost

ECHO.

ECHO Configuração Completa!!

#########################

Bom, após fazer isso, o SCCM poderá ser instalado, não gerando problemas posteriores.

Mas e se eu já tiver instalado o SCCM, precisarei reinstalar tudo ?? Não, execute o script e na sequência, entre no Primary Site / Site Settings / Site Systems, selecione o seu Servidor

image

Após isso, no seu painel do lado direito, você irá excluir o seu Distribution Point e reinstalá-lo

image

Pronto, o seu problema deverá estar resolvido.

[]´s

Flávio J Medeiros

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: